Skip to main content

Impulse Sprinkler Spike - Troubleshooting Guide

Find quick tips and step-by-step advice to resolve issues with your Hoselink Impulse Sprinkler Spike.

Updated over a month ago

If your Hoselink Impulse Sprinkler Spike is not working as expected, use this article to identify the issue and resolution.

Warranty: 12 month warranty


Head Has Stopped Rotating

Symptom:

The head of the Impulse Sprinkler is no longer rotating, resulting in the water shooting a single stream of water, rather than dispersing evenly across the intended area.

Cause

  • Low water pressure - not having adequate water pressure for it to rotate.

Resolution

  1. If the Impulse Sprinkler head has stopped turning, check for blockages by removing the Hoselink Accessory Connector and sprinkler head, then rinse both with warm water. Running warm water through the system with the head removed will remove any debris caught inside. Afterwards, spray the tool with silicone lubricant to prevent future blockages.

  2. Replace the Impulse Sprinkler Head. Replacement heads can be obtained by contacting Customer Support.


Leaking from between Brass Thread and Hoselink Accessory Connector

Symptom:

A leak is occurring between the brass thread on the Impulse Sprinkler Spike and where the Hoselink Accessory Connector screws in.

Cause

  • Damaged Accessory Connector.

  • Damaged or worn down Washer.

Resolution 1: Swap Accessory Connectors

Instructions:

  1. Unscrew the Hoselink Accessory Connector from the side of your sprinkler.

  2. Take a known working Accessory Connector from another Hoselink accessory (such as a spray gun or a different sprinkler) and screw it into the leaking sprinkler unit.

  3. Turn on the water and see if leak continues or has stopped.

Resolution 2: Replace the Washer

If swapping Accessory Connectors did not resolve the leak, follow the below instructions

  1. Unscrew the Hoselink Accessory Connector from the brass threaded connection and replace the 3/4 inch washer. Replacement 3/4 inch washers can be purchased online HERE.

    If leaking persists after replacing the washer then a replacement sprinkler is required. The Impulse Sprinkler Spike has a 12 month warranty. To start a warranty claim, contact Customer Support.


Leaking from between Brass Thread and Body of the Impulse Sprinkler Spike

Symptom:

A leak is occurring between the brass thread and the main body of the Impulse Sprinkler Spike.

Cause

  • Dropping the sprinkler causing weakness overtime.

Resolution

If a leak is occurring between the brass thread and the main body of the Impulse Sprinkler Spike, this cannot be repaired and a replacement sprinkler will be required. The Impulse Sprinkler has a 12 month warranty. To start a warranty claim contact Customer Support.


Broken Spike

Symptom:

The spike has broken away from the body of the Impulse Sprinkler Spike.

Cause

  • The ground is very dry and hard.

Resolution

We recommend ensuring the ground is not solid before attempting to spike the Impulse Sprinkler into the ground. Firstly, water the area to soften, before inserting.

If the spike has broken on the Impulse Sprinkler Spike it's not going to be repairable and a replacement will be required. The Impulse Sprinkler Spike has a 12 month warranty. To start a warranty claim contact Customer Support.

Did this answer your question?